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Clustering VirtualCenter 2.5  
Using Microsoft Cluster Services 

This paper documents the steps to successfully implement a high availability solution for 
VirtualCenter 2.5 using Microsoft’s cluster services. There are some basic requirements 
to start the process. Microsoft requires Active Directory for cluster services. Additionally, 
Windows 2003 Enterprise server or higher will be necessary. This document was 
compiled from several sources. It demonstrates creating a VC cluster on the same ESX 
host (cluster-in-a-box) with a SAN-based quorum disk. The hyperlinks at the end of the 
document has more detailed information for other types of configurations, such as, 
cluster-across-boxes and physical-to-virtual. 

Note: This is not an official VMware whitepaper or document. This is simply a record of 
one man’s journey to satisfy the quest for knowledge. Please use at your own 
discretion. 

This document assumes the following configuration: 

• VirtualCenter 2.5 

• ESX 3.5 

• Windows 2003 R2 Enterprise server 

• Active Directory Domain 

 
Creating the First Node of the Cluster 
In this section, creating the first node of the cluster requires pre-creating an 
eagerzeroedthick virtual disk, and then creating a virtual machine using that pre-
created disk, and lastly installing the operating system. 

1. Start by creating directory in the datastore to which the virtual machine’s boot 
disk will reside. For example, using PuTTY, change to the local VMFS and type: 
#cd /vmfs/volumes/sc-esxhost\:LocalVMFS/ 

#mkdir VCnodeA 

#cd VCnodeA 

2. Now create a vmdk for the virtual machine’s boot disk using vmkfstools and 
the eagerzeroedthick argument. This will create 4GB virtual disk: 

#vmkfstools –c 4G –d eagerzeroedthick –a lsilogic vcnodea.vmdk 

 

3. When finished, create a new virtual machine using the existing disk created in 
step 2. 
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4. Make sure to install VMware Tools and disconnect CD-ROM. Shut down 
VCNodeA. 
 

Creating the Second Node of the Cluster 
1. Cloning the first node and customizing it for uniqueness is the fastest way to 

create the second cluster node.  
2. Join both nodes to the Active Directory domain. 

 

Adding the Quorum Disk to the Cluster Nodes 
1. Create a quorum disk to be used by Microsoft Cluster services using the same 

vmkfstools command previously. Locate this disk locally or on a shared LUN. 
#vmkfstools –c 2G –d eagerzeroedthick –a lsilogic                   

/vmfs/volumes/SharedLUN/quorum/quorum.vmdk 

2. Power off both nodes. Start with VCNodeA by going to VM > Edit Settings and 
click the Add.. button and select Hard Disk from the device listing. Click Next. 

 
3. On the Select a disk page, choose the radio button, Use an existing disk and 

click Next. 
4. Browse to the location of the quorum disk, select it and click Next. 
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5. On the Specify Advanced Options page, choose a new SCSI device node. The 
quorum disk must reside on a different SCSI controller. Use SCSI(1:0), for 
example. Click Next, then Finish. 
Note: These must identical setting for both nodes! 

 
6. Now select the newly added SCSI controller. For the SCSI Bus Sharing, choose 

Virtual, then click Ok. 

 
7. Power on VCNodeA. 
8. Click the Start button, then right-click My Computer and choose Manage. 

 
9. Select Disk Management in the left pane. An Initialize and Convert Disk 

Wizard should begin. The quorum disk that was just added is not initialized nor 
formatted. Click Next to begin. 
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10. At this point, the quorum disk should be initialized, but not converted. To do this, 

click Next twice, then Finish. 
11. Now that the disk is online, select the unallocated disk, right-click then New 

Partition… 

 
12. Click Next four times. At the Format Partition dialog box, change the volume 

label to Quorum or whatever name and check Perform a quick format. Click 
Next, then Finish. 

 
12. Close all windows and shut down VCNodeA. 
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13. Repeat steps 2-10 for VCNodeB, if necessary, making sure the same drive letter 
is assigned. 
Note: At this point, it is important to not allow both nodes to be powered on 
simultaneously. After the Cluster Services configuration is complete, both nodes 
with support running at the same time. 

 

Preparing for Microsoft Cluster Services 
In this section, several steps will need to be performed on both nodes to support Cluster 
Services. Many of the following procedures are considered by Microsoft to be best 
practices. 

Networking 
 
Perform the following operations on both cluster nodes. Power only one on at a time. 

1. On both nodes, add a second NIC connected to its own private network. On the 
ESX host, create a virtual machine port group called, such as Private. 

2. Both NICs in both virtual machines should have static IP addresses. 
3. Change the binding order of the NICs in each virtual machine. Make sure to list 

the Public connection first followed by the Private connection. From within 
the operating system of each node, click Start > Control Panel, right-click 
Network Connections > Open. 

 
2. To change the binding order, select the menu option, Advanced > Advanced 

Settings… 
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3. Using the elevator buttons, adjust the network connections so that Public is 
listed first, followed by Private. Click Ok. 

 
Repeat this for the second node. 

4. Next, modify the Private connection’s TCP/IP settings by right-clicking anf 
choosing Properties. Double-click Internet Protocol (TCP/IP) in the list and 
then Advanced... 

5. Click the DNS tab and verify there are no DNs addresses. Make sure Register 
this connection’s address is registered and Use this connection’s DNS 
suffix in DNS registration boxes are deselected. 

 
6. Select the WINS tab and verify that Enable LMHOSTS lookup is unchecked and 

Disable NetBIOS over TCP/IP is selected. 
7. Close all dialog boxes and shutdown the virtual machine. 
8. Repeat these steps for VCNodeB. 

Creating a Cluster User Account 
 

1. Launch the Active Directory Users and Computers on the domain controller and 
create a new domain user using the following: 

a. User Cannot Change Password 
b. Password Never Expires 
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Configuring Microsoft Cluster Services 

Configuring the First Cluster Node 
1. Start VCNodeA. 
2. Click Start > All Programs > Administrative Tools > Cluster Administrator. 
3. Once the application starts, choose Create a cluster from the drop-down menu 

and click Ok. 

 
4. Click Next on the wizard page. Choose the domain from the drop-down list and 

enter a name for the MSCS cluster. Click Next. 

 
5. If the first cluster node does not default to the computer’s name, browse the 

correct node and click Next. 
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6. At this point, Cluster services will be installed and configured on VCNodeA. 
When it completes, click Next. 

 
7. Enter an address that will represent the MS cluster’s managed IP. This is not the 

application’s managed IP address. Click Next. 
8. Enter the service account’s credentials created earlier in the domain. Click Next. 
9. Review the Summary page and click Next. 
10. Again, when complete the cluster should be green. 

 
11. Click Next and Finish to complete the VCNodeA cluster setup. 
12. Within the Cluster Administrator application, verify that VCNodeA is online. 
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Configuring the First Cluster Node 
1. If VCNodeB is not already powered on, do so now. 
2. From the Cluster Administrator menu, choose File > New > Node 

 
3. Using the wizard, browse to the second node and choose Add. Click Next. 

 
4. When the configuration completes, click Next. 
5. Enter the password for the cluster service account. Click Next twice. 
6. Again, click Next followed by Finish. 
7. That completes the Microsoft Cluster Services. The next task will be to cluster 

VirtualCenter. 
Note: Make sure that Host (A) records are added to the DNS zone for both the MS 
cluster managed IP address and the VirtualCenter cluster managed IP address 
 

Modifying the Windows Operating System 
As a Microsoft best practice, set the I/O timeout value to 60 seconds or more within the 
cluster nodes operating system. To verify this, use the Windows registry editor, 
regedit.exe, and check the value: 
 

HLKM\System\CurrentControlSet\Services\Disk\TimeOutValue 
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Clustering VirtualCenter Services 
Although VirtualCenter is not a “cluster aware” application, it’s supporting services can 
be set up in an active-passive configuration. The first section starts this configuration 
assuming VirtualCenter is installed into the first node, VCNodeA, and is using a SQL 
server database on a separate server. Of course, SQL Server is a “cluster aware” 
application and can be setup to be clustered as well. 
 

1. Verify that VirtualCenter works by logging in VI client. Once that’s complete, stop 
the VirtualCenter service and the License server service in VCNodeA. 
Start > All Programs > Administrative Tools > Services 

2. Install VirtualCenter into VCNodeB using the same ODBC connector, database 
and license file. When prompted to reinitialize the existing VirualCenter 
repository, click No. 

 
3. Click Ok twice to accept the notifications. Next, browse to the license file and 

click Next three times. 
4. Click Install to begin. 
5. Once the install is complete and the services have been verified, stop the 

VirtualCenter service and License server as before. 
6. Go back to VCNodeA and start the VirtualCenter service and License service. 

Copying the Certificates for VirtualCenter 
In order to successfully failover in a cluster configuration, both nodes in the 
VirtualCenter cluster have to have identical certificates. This will not cause a conflict 
since VirtualCenter does not permit two VirtualCenter instances to simultaneously 
access the same database. They do, however, have to present the same credentials to 
the database. With the release of VirtualCenter 2.5, the database password is now 
stored in encoded form using the certificate. The challenge is that the certificate is 
generated for each VirtualCenter instance. It will be necessary to reset the database 
password on the first node, copy it over to the second node and reset it there as well. 
Once that is complete, both nodes will have the same encoded password in their 
respective certificates and the failover should be seamless. 
 

1. Once the services have been restarted on VCNodeA, open a command prompt 
and navigate to: 
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C:\Program Files\VMware\Infrastructure\VirtualCenter Server 

2. Now execute, vpxd.exe –p to reset the database password to whatever you 
want. 

3. Now stop the VirtualCenter service again on VCNodeA. 
4. On VCNodeA, navigate to: 

C:\Documents and Settings\All Users\Application 
Data\VMware\VMware VirtualCenter\SSL 

5. Copy the certificates in this directory over to VCNodeB replacing that node’s 
certificates. 
Note: It might be a good idea to rename VCNodeB’s certificates first in case they 
need to be referred back. 

6. On VCNodeB, perform steps 1-2 using the same password as VCNodeA. 
7. Start the VirtualCenter service and make sure VI client can connect. 
8. Stop the VirtualCenter service on VCNodeB and restart VCNodeA’s. 

Creating a VirtualCenter Cluster Group in MSCS 
 
Although cluster services previously implemented, that was to establish the nodes 
involved and identify an owner of the cluster services. It is now necessary to create a 
new cluster group to specifically manage clustering for VirtualCenter and supporting 
services separately. 

1. Start the Cluster Administrator on VCNodeA. 
2. Right-click Groups and select New > Group. 

 
3. Enter a name and/or description for the VirtualCenter cluster and click Next. 
4. Click Finish without adding any owners. Click Ok. 



  

Chris C. Skinner Page 12 6/24/2008 

5. Select the newly created cluster group, then right-click and choose New > 
Resource. 

6. The first step is create a single, managed IP address to be used for accessing 
the VirtualCenter cluster.  
Note: Make sure that the IP address being assigned has a Host (A) record in the 
DNS zone. 
Enter a name and choose IP Address from the drop-down list. Check the box, 
Run this resource in a separate Resource Monitor. Click Next three times. 

 
7. Now enter the IP address to be used for managing access to the VirtualCenter 

cluster. Pick the appropriate public facing network and click Finish. Click Ok. 
8. Create another resource per step 5. The Resource Type should be Network 

Name. Click Next twice. 

 
In the Dependencies screen, add the VC Managed IP resource as a 
dependency. Select the box Run this resource in a separate Resource 
Monitor. Click Next three times. 
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9. Enter the name defined for the Host (A) record in step 6. Check both boxes and 
click Finish and Ok. 

 
10. Create another resource for the VirtualCenter service. Choose Generic Service, 

check the box and click Next twice. 

11. Add the VC Name as its dependency. Enter vpxd as the Service Name and 
check Use Network Name from computer name. Click Next and Finish and 
then Ok. 

 
12. Create a resource for the web service. Choose Generic Service, check the box 

and click Next twice. 

 
13. Add the VC Service as its dependency. Enter webAccess as the Service Name 

and check Use Network Name from computer name. Click Next and Finish 
and then Ok. 
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14. Create the last resource for the license service. Choose Generic Service, check 
the box and click Next twice. 

 
15. Add the VC Service as its dependency. Enter VMware License Server as the 

Service Name and check Use Network Name from computer name. Click 
Next and Finish and then Ok. 

 
16. That will complete the cluster group for the VirtualCenter server and its 

supporting services. 
17. Lastly, launch the VI client, log into VCNodeA, and enter the managed IP 

address defined for the VirtualCenter cluster. Click Administration > 
VirtualCenter Management Server Configuration… from the menu. Select 
Runtime Settings and enter managed IP address defined in step 7. Click Ok. 
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18. Back in the Cluster Administrator application, bring the VC cluster online. Right-

click the VC Cluster group and choose Bring Online. 

 
19. At this point, the cluster should be online and running. 
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20. To test the VirtualCenter cluster, right-click the VC Cluster and choose Move 
Group. This should take the VCNodeA offline and bring the VCNodeB online. 

 
21. Log into VirtualCenter with VI client using the managed DNS/IP address defined 

for the cluster and register the ESX hosts. 
 

Additional Resources 
The following are additional links to some documents that can provide additional 
information and alternatives, such as physical-to-virtual and cluster-across-box 
configurations. Additionally, there are some links to VMware whitepapers which 
provided some of the inspiration for this project. 
 

Using MSCS to Cluster VirtualCenter (VirtualCenter 2.0.1 Patch 2) 
http://www.vmware.com/pdf/VC_MSCS.pdf 
 

Guide to Creating and Configuring a Server Cluster under Windows 2003  
http://www.microsoft.com/downloads/details.aspx?familyid=96F76ED7-9634-4300-
9159-89638F4B4EF7&displaylang=en 

 

Technical Overview of Windows Server 2003 Clustering Services 
http://www.microsoft.com/windowsserver2003/techinfo/overview/clustering.mspx 
 


